Luke Carrier

Getting the Android SDK playing nicely with Fedora x86_64

Published 4 years ago

You'll need to install some 32-bit dependencies and restart Eclipse for aapt, adb and co to work correctly. I'd love to see a native 64-bit SDK, but I doubt it'll happen for a while because of the specialised nature of the tools. Still, the fix is simple enough.

$ sudo yum -y install \
        alsa-plugins-pulseaudio.i?86 glibc.i?86 libstdc++.i?86 libX11.i686 \
        libXrandr.i686 ncurses-libs.i?86 SDL.i?86 zlib.i?86